Sprint-Layout 5

Sprint-Layout 5.0

Sprint-Layout 5.0- простая программа для создания двухсторонних и многослойных печатных плат. Программное обеспечение включает в себя многие элементы, необходимые в процессе разработки полного проекта. В нее включены такие профессиональные возможности, как экспорт Gerber- файлов или HPGL-файлов, в то время как основа программы Sprint-Layout была сохранена.

Sprint-Layout позволяет наносить на плату Контакты, SMD-контакты, проводники, полигоны, текст и так далее. Контактные площадки могут быть выбраны из широкого набора.

Существует два слоя – меди и компонентов - для каждой стороны платы. Дополнительно можно использовать слой формы платы, а также 2 внутренних слоя для многослойных плат. Дополнительные особенности – маска по олову, SMD-маска, металлизация, контроль и т.д.

Интегрированный автотрассировщик может быстро проложить проводники.

Фотовид позволяет увидеть плату в почти реальном виде. Это помогает найти ошибки в создании платы.

Библиотека имеет возможность добавления компонентов.

Программа предоставляет возможность выбора вариантов изменения печати.

Поддержка форматов Gerber- и Excellon позволяет передачу файлов разработанных плат на профессиональное производство.

HPGL-формат также поддерживается. Программа позволяет создать экспортный файл HPGL для обработки платы на фрезерном станке с программным управлением.


Новые возможности

Многослойность

Для увеличения возможностей добавлены 2 новых внутренних слоя.

Слой формы

На этом слое можно создать, например, контур платы сложной конфигурации.

Свободное вращение

Позволяет поворачивать элементы на любой угол.

Масштаб - колесиком

Изменять масштаб изображения можно простым вращением колесика мышки.

Панель свойств

Панель свойств позволяет без дополнительного вызова диалогового окна изменять параметры выделенных элементов.

Функция DRC

Эта функция позволяет произвести контроль созданной платы по заданным параметрам, например, ширине проводников, диаметрам отверстий, и т.д.

Создатель макросов

Эта функция упрощает создание контактных площадок для компонентов.

Удаление масок

Маска по олову может быть удалена с конкретного контакта или наложена на проводник.

SMD-клей

Создание специального файла для нанесения на плату пасты, прикрепляющей SMD-компоненты при

Автоматизированном производстве.

Единицы в "мм" или "мил"

Функция позволяет сделать выбор единиц измерения в мм или милах (1 мил = 1/1000 дюйма).

Клавиши клавиатуры

При использовании клавиатуры сокращается время, необходимое для вызова той или иной функции.

Спираль

Функция создания спирали может быть использована при работе с ВЧ-платами.

Виртуальные узлы

Эти узлы расположены в середине каждой проведенной линии. При перемещении такого узла будут автоматически созданы дополнительные виртуальные узлы. Это упрощает редактирование линий.

Термобарьер

Функция позволяет создавать термобарьер у контактных площадок, соединенных с металлизацией.

Изолирующие дорожки

Вычисление параметров изолирующих дорожек теперь производится намного быстрее.

Контроль

Функция контроля теперь позволяет учитывать металлизацию.


Регистрация программного обеспечения

Вы можете послать нам вашу регистрационную форму, получать информацию об обновлениях и новых продуктах ABACOM.

Если Вы получили ваше программное обеспечение непосредственно от ABACOM, регистрация не нужна.


Свойства платы

Начало создания новой платы следует делать с определения ее характеристик. Для этого необходимо выбрать пункт Свойства платы из меню Проект или щелкнуть правой кнопкой мышки по рабочему полю и в открывшемся меню выбрать пункт СВОЙСТВА.

При этом в правой части экрана появится панель Свойства.

В этой панели производится установка характеристик платы.

Размер платы не может превышать габаритов 300 x 300 мм.

При выборе Многослойная появляются 2 дополнительных внутренних слоя В1 и В2, предназначенных для трассировки платы.

Окно свойств может быть вызвано в любой момент для внесения необходимых изменений.


Параметры сетки

Сетка позволяет размещать элементы на плате точно и очень эффективно. Сетка видна на экране до тех пор, пока это позволяет выбранный масштаб и параметры монитора.

Выключать привязку элементов к сетке следует, удерживая нажатой клавишу CTRL на клавиатуре.

При необходимости, шаг сетки можно изменить в любой момент. Это не повлияет на расположение элементов. Если элемент не устанавливается в требуемое место, следует выбрать более мелкую сетку или отключить привязку к ней. По умолчанию установлен шаг 1/10 Дюйма (=2,54 мм) или кратный ему.

Для изменения параметров сетки следует щелкнуть по соответствующему значку:

При этом появится всплывающее меню:

В меню предлагается 7 значений шага по умолчанию, как правило, достаточных для любых плат. Но по желанию список можно дополнить собственными значениями. Для этого следует выбрать Д обавить шаг сетки в всплывающем меню и установить требуемое значение. Для установки доступны величины от 0,01 мм до 99,9 мм. При подтверждении ввода сетка будет добавлена и активизирована на рабочем поле.

Добавленные пользователем шаги сетки будут внесены во всплывающее меню. Для удаления неиспользуемого шага сетки его следует выбрать и нажать на пункт У далить шаг сетки (Выбранная сетка обозначена с галочкой.)

Примечание:

Привязка к растру сетки отключается при нажатой клавише CTRL клавиатуры.

Выделенная сетка

По умолчанию каждая 5 линия сетки утолщена. Изменять это состояние следует во всплывающем при наведении на пункт Выделенная сетка меню.

Включение/выключение отображения сетки

В последнем пункте данного меню щелчком левой кнопки мышки можно включать и выключать отображение сетки.


Слои платы

В программе предусмотрена возможность использования 7 слоев. На экране они отображаются в виде полупрозрачных рисунков.

Расположение слоев:

  • Сторона платы М1 – медное покрытие верхнего слоя
  • Сторона платы К1 – компоненты, размещенные на верхнем слое
  • Сторона платы М 2 – медно покрытие нижнего слоя
  • Сторона платы К 2 – компоненты, размещенные на нижнем слое
  • Ф – слой для создания принципиальной схемы или сложного контура платы
  • I1 -внутренний слой 1 (только для многослойной платы)
  • I2 -внутренний слой 2 (только для многослойной платы)

Верхняя и нижняя стороны имеют по два слоя – для создания проводников и для установки компонентов.

Следует обратить внимание:

  • Сторона платы 1 - верх платы.
  • Сторона платы 2 - низ платы.
  • Устанавливать элементы следует, как будто плата прозрачна.
  • Компоненты и тексты на нижней стороне платы (сторона 2) должны быть зеркальны (по умолчанию программа их так и ставит),

Только один из слоев может быть активным в данный момент. Это означает, что все новые элементы будут помещены в активный слой. Если слой меди активен, весь рисунок будет сделан в виде проводников. Если активен слой компонентов, рисунок будет сделан непроводящими линиями.

В нижней части экрана можно выбирать активность и видимость слоев:

Кнопки М1, К1, М2, К2, В1, В2 и Ф переключают соответствующие видимые/невидимые слои. Текущий активный слой всегда видим.

Кнопки с установкой точки выбирают активный слой.

Щелчком левой кнопки мышки по значку "?" вызывается информация о слоях:

Эта картинка показывает назначение и цвета слоев.


Линейки и координаты

Правители

Рядом с рабочим полем постоянно отображаются две координатные линейки.

Единицы отображения на линейках переключать между мил (1 мил = 1/1000 дюйм) и миллиметр (мм) щелчком левой кнопки мышки по значку, расположенному в месте пересечения линеек.

Координаты

Текущее положение курсора отображается в левом нижнем углу экрана. Единицы измерения соответствуют единицам линеек.

Начало координат

По умолчанию началом координат является левый верхний угол платы. Это место маркируется синей точкой на рабочем поле. Для выбора новой точки отсчета следует щелкнуть по синему маркеру левой кнопкой мышки и, не отпуская кнопку, переместить точку отсчета в новое место.

Если точка начала координат не видна на рабочем поле, ее можно вызвать. Для этого необходимо щелкнуть правой кнопкой мышки по свободному участку рабочего поля и появившемся всплывающем меню выбрать Координаты «0».

При выборе П о щелчку мышки, точка отсчета будет установлена в том месте, в котором был произведен щелчок правой кнопкой.

Примечание:

Для установки начала координат без привязки к сетке, следует удерживать нажатой клавишу Ctrl.


Основные элементы

В программе имеются все необходимые элементы для создания рисунка печатной платы.

  • Проводники
  • Контактные площадки
  • SMD-контакты
  • Кольца / Дуги
  • Полигоны
  • Фигуры
  • Текст

На левой панели программы предлагается сделать выбор требуемого элемента. По умолчанию выбран курсор – режим редактирования. Он используется для выделения, перемещения, копирования и удаления объектов.

Примечание:

При щелчке правой кнопкой мышки на рабочем поле появляется всплывающее меню, в котором предлагается выбор наиболее часто используемых действий.

Выделение объектов

Для проведения каких-либо изменений с элементом, его необходимо предварительно выделить. Для этого следует навести курсор на желаемый элемент и щелкнуть по нему левой кнопкой мышки. Выделенный элемент изменит цвет. Если необходимо выделить несколько разных объектов, следует щелкнуть левой кнопкой мышки за пределами области попадания объектов и, удерживая кнопку нажатой, выделить область на рабочем поле, в которую попадают все выделяемые элементы.

Если необходимо добавить или удалить из выделения одиночный объект, следует, удерживая нажатой клавишу SHIFT на клавиатуре, щелкнуть по нему левой кнопкой мышки.

Перемещение объектов

Для перемещения элемента его необходимо выделить и, удерживая нажатой левую кнопку мышки, перетащить вслед за курсором в требуемое место..

Удерживая нажатой клавишу CTRL клавиатуры, можно перемещать объект без привязки к сетке.

Примечание:

Для перемещения можно также использовать Стрелки клавиатуры.

Удаление объектов

Для удаления элемента его необходимо выделить. Функция Удалить доступна из меню Редактор главного меню или из панели инструментов. Также можно использовать клавишу <DEL> клавиатуры.


Проводник

Для нанесения проводника на плату необходимо выбрать:

Затем следует переместить курсор в требуемую точку. Первый щелчок левой кнопки мышки определяет начало проводника. Переместив курсор в следующую точку, вновь следует щелкнуть левой кнопкой. При этом произойдет установка проводника. Переместив курсор вновь, можно получить очередную точку и т.д. Использовать клавишу SPACE необходимо для получения требуемых перегибов линий проводников. Для выхода из режима необходимо щелкнуть правой кнопкой.

Примечание:

Для отключения привязки к сетке следует использовать клавишу CTRL.

Выбор ширины проводника осуществляется в окошке:

Минимально возможная ширина зависит от используемых систем (экран, принтер, и т.д.). При установке ширины, равной нулю, можно получить самую тонкую линию.

Наиболее часто используемые значения ширины для удобства следует заносить и хранить в местном всплывающем меню, которое открывается при щелчке по кнопке выбора ширины. Для добавления нового значения необходимо выбрать Д обавить. После этого можно выбирать добавленные значения непосредственно из всплывающего меню. Аналогичным образом следует производить удаление, выбрав У далить.

Изменение нанесенных проводников

Чтобы изменять существующий проводник, его необходимо выделить.

Точки перегибов (узлы) становятся окрашенными в синий цвет. Нажав левую кнопку мышки и потянув за узел, можно переместить его в новое место.

Для удаления или добавления узлов, необходимо по выбранному узлу щелкнуть правой кнопкой мышки и в появившемся окне выбрать требуемое действие.

При выделении проводника его ширина отображается в окошке, окрашенном в красный цвет. Изменяя это значение можно изменять ширину выделенного проводника.

Виртуальные узлы

Эти узлы расположены в середине каждой прямой линии проводника. Установив курсор на такой узел и перемещая его в новую точку, получают новый узел и 2 дополнительных виртуальных узла. Это упрощает редактирование проводников.


Контактные площадки

Для установки контактных площадок следует выбрать значок на левой панели:

Программа предлагает несколько форм площадок. Текущая форма показана на кнопке. Для выбора другой, необходимо нажать на стрелку и в появившемся меню произвести выбор.

Если выбрана функция с металлизацией, контактная площадка появится с обеих сторон платы, а при многослойной плате и на внутренних слоях. Такие площадки будут отображаться другим цветом и красным отверстием.

Переместив курсор на рабочее поле щелчками левой кнопки мышки следует устанавливать контактные площадки в требуемые места. Щелчок правой кнопкой прекращает операцию установки (для этой цели можно воспользоваться также клавишей <ESC>).

Внимание:

Контактные площадки всегда имеют отверстие. Это отверстие появится и в том случае, если контактная площадка была установлена в место, покрытое слоем меди.

Примечание:

Для отключения привязки к сетке следует удерживать нажатой клавишу CTRL.

Диаметры площадки и отверстия:

Для добавления или удаления новых сочетаний величин следует щелчком левой кнопки мышки по значку контактной площадки, расположенному в левой нижней части экрана, вызвать всплывающее меню.

Редактирование контактных площадок

При выделении установленной контактной площадки ее параметры будут отображаться в окне значений на красном фоне. Изменяя эти значения, можно менять параметры выбранной площадки. При выборе нескольких контактных площадок с разными параметрами, изменения будут вноситься во все площадки одновременно.

Если панель Свойства находится на экране, редактировать площадку можно здесь:

Термобарьер доступен только в том случае, если произведена металлизация платы. Форма термобарьера такова:

Контактные площадки с термобарьером легче поддаются пайке.

Металлизация отверстий

При металлизации отверстий контактные площадки сторон соединены между собой сквозь плату.

При необходимости установить такую площадку следует выбрать пункт с металлизацией во всплывающем меню формы контактных площадок или выбрать соответствующий пункт в панели свойств.

Примечание

Металлизация отверстия выбранной контактной площадки может быть произведена клавишей F12.

Простые отверстия

Если необходимо сделать на плате отверстие для крепления и т.п., следует в параметрах контактной площадки установить диаметр отверстия равным диаметру контакта и не включать металлизацию (во избежании головных болей производителя печатных плат). Такие отверстия будут отображаться с перекрестием по центру.


SMD-контакты

Для установки на плату smd-контактов необходимо выбрать соответствующий значок на левой панели программы:

Переместив курсор на рабочее поле, щелчком левой кнопки мышки производят установку. Правая кнопка или клавиша ESC служат для выхода из режима.

Примечание:

Для установки вне растра сетки следует удерживать нажатой клавишу CTRL.

Размер SMD-контактов следует устанавливать в левой нижней панели программы:

Для создания собственного списка разных размеров контактов следует щелчком левой кнопки мышки по значку контакта в этой панели вызвать всплывающее меню. Выбрав Д обавить, добавляют новые размеры в список. Для удаления следует использовать пункт У далить.

Редактирование SMD-контактов

При выборе на рабочем поле smd-контакта его параметры отображаются на красном фоне панели параметров smd-контактов. Изменяя их, производят изменение вида выбранного smd-контакта. При выделении нескольких контактов вносимые изменения приведут к изменению всех выбранных.


Дуга

Кольцо/Дуга

Для вызова этой функции необходимо щелкнуть левой кнопкой мышки по значку:

Далее следует переместить курсор в требуемое положение центра дуги и, щелкнув левой кнопкой мышки, обозначить этот центр. Не отпуская кнопки, протянуть курсор до получения требуемого диаметра. При отпускании кнопки формирование будет закончено. Щелчком правой кнопки мышки осуществляется выход из режима Дуга.

Примечание:

Удерживая нажатой клавишу CTRL, можно отключить привязку к сетке.

Изменение ширины контура дуги

Контур дуги имеет ту же ширину, что и проводники. Для его изменения следует установить требуемое значение в окошке выбора ширины проводника.

Формирование дуги

Получившаяся окружность может быть преобразована в дугу. Существует два способа осуществления этой операции. Начало и окончание замкнутого круга изначально находятся в одной точке. Установив курсор на эту точку, следует нажать левую кнопку мышки и, удерживая ее нажатой, протянуть курсор по окружности против часовой стрелки до получения требуемой дуги. При отпускании кнопки формирование дуги закончится.

Для редактирования параметров дуги можно воспользоваться панелью Свойств. Сначала следует произвести выделение, а затем установить требуемые значения.


Полигон

Полигоны - заполненные области (многоугольники). Полигоны, связанные на печатной плате с некоторыми из элементов, также можно назвать слоем металлизации. Заполнение внутренней зоны полигона происходит автоматически.

Для выбора этого режима необходимо щелкнуть левой кнопкой мышки по значку:

Далее следует переместить курсор в нужную точку на плате и щелкнуть левой кнопкой мышки, обозначив первую точку многоугольника полигона. Затем курсор переводится в следующую точку, на которой вновь делается щелчок. Постепенно перемещая курсор от точки к точке, следует выделить зону покрытия полигона. При щелчке по первой точке после окончания выбора зоны, происходит автоматическое заполнение всей выделенной области. При двойном щелчке на очередной точке, зона полигона автоматически закроется по кратчайшему пути. Для изменения линии изгиба следует использовать клавишу Space. Для выхода из режима необходимо щелкнуть правой кнопкой мышки.

Примечание:

Удерживая нажатой клавишу CTRL клавиатуры, отключают привязку к сетке.

Ширина контура полигона выбирается в панельке:

Ширина 0 заставит устройство печати проводить самую тонкую линию, которая является доступной для данного принтера.

Редактирование полигона

Для редактирования полигона его следует выделить. При этом узловые точки окрасятся в синий цвет.

Щелкая по ним правой кнопкой мышки, вызывают всплывающее меню, в котором можно выбрать пункты добавления или удаления узлов.

Виртуальные узлы

Эти узлы расположены в середине каждой прямой линии контура полигона. Потянув за такой узел, можно создать еще 2 виртуальных узла, расположенных по обе стороны от редактируемого. Это упрощает формирование линии контура.

При выделении полигона ширина контурной линии будет отображаться в красном прямоугольнике в нижней части окна программы слева. Изменяя эту величину, можно менять ширину линии контура.

При выделении полигона и его перемещении в новое расположение, в левом нижнем углу будут отображаться в красном прямоугольнике координаты смещения. Это поможет в случае необходимости вернуться в исходную точку.

Для выбора параметров полигона следует вызвать панель Свойства:

С сеткой

При выборе этого режима внутренняя область полигона будет заполнена не полностью, а пересекающимися линиями, ширина которых равна ширине линии контура или выбрана по усмотрению автора проекта.


Фигуры

В этом режиме можно создавать 2 наиболее употребляемые фигуры:

  • Равносторонние многоугольники
  • Спирали

Спирали главным образом необходимы при создании ВЧ-устройств.

Для активизации режима следует выбрать в левой панели программы значок:

Многоугольник

Необходимо выбрать следующие параметры:

  • Радиус (измеренный от центра до углов)
  • Ширина линии
  • Число вершин (от 1 до 99)
  • Поворот (изменяет угол начала в диапазоне–180 °... +180 °)
  • Заливка – внутренняя область многоугольника будет заполнена цветом активного слоя.

При нажатии на кнопку ОК многоугольник переносится на плату.

Спираль

Для создания спирали требуется ввести следующие параметры:

  • Начальный R - (радиус внутреннего кольца)
  • Шаг - (расстояние между линиями спирали)
  • Ширина линии
  • Количество витков

Нажатием на кнопку ОК спираль переносят на рабочее поле платы.

Примечание:

Для отключения привязки к сетке во время установки на плату следует удерживать нажатой клавишу CTRL.

Изменение существующих многоугольников или спиралей

Все элементы сгруппированы. Их можно разгруппировать и редактировать точно так же, как любой другой элемент платы.


Текст

Для нанесения на плату текстовой информации необходимо выбрать в левой панели программы:

При этом на экране появляется диалоговое окно:

В это окно следует вписать требуемый текст и выбрать его параметры.

Для маркировки последовательности компонентов можно выбрать автоматическое добавление номера к символу компонента (как R1, R2...).

Примечание:

Для установки текста вне растра сетки следует удерживать нажатой клавишу CTRL.

Изменение существующего текста

Двойной щелчок по тексту вновь вызывает диалоговое окно выделенного текста, в котором можно сделать требуемые изменения.

Если панель Свойства находится на экране, редактировать текст можно в ней:

Диалоговое окно при этом вызывать не требуется.


Использование буфера обмена

Для выделенных объектов существует ряд функций, использующих буфер обмена:

  • Вырезать
  • Копировать
  • Вставить
  • Дублировать

Эти функции также доступны для выбора на панели инструментов.

Вырезать

Копирует выделенные элементы в буфер обмена и удаляет их с рабочего поля.

Копировать

Копирует выделенные элементы в буфер обмена. Элементы остаются на рабочем поле.

Вставить

Одним щелчком мышки элементы из буфера обмена устанавливаются на рабочем поле.

Дублировать

За одно действие выполняются две операции – копировать и вставить.

Примечание

При копировании элементов в программе Sprint Layout, запись производится в общий для всего

компьютера буфер обмена. Поэтому имеется возможность затем вставить скопированные элементы в другие программы. Следует учитывать, что эти программы должны поддерживать

EMF-формат.


Масштаб изображения

Изменение масштаба изображения помогает при создании плат. Масштаб можно изменять разными способами.

Колесико мышки

Лучший и самый легкий способ изменить масштаб изображения. Установив курсор в требуемую часть экрана, вращением колесика добиваются требуемого масштаба.

Выбор области изменения масштаба

Для отображения во всем рабочем поле небольшого участка платы следует выбрать на левой панели задач значок:

Установить курсор в требуемое место и нажать левую кнопку мышки. Удерживая кнопку нажатой, протянуть курсор по плате, выделяя необходимый участок. При отпускании кнопки выделенная область расширится на все рабочее поле.

Дополнительно на панели задач можно выбрать:

Предыдущий масштаб

Возвращает размер изображения к предыдущему масштабу.

Вся плата

Масштаб устанавливается таким, при котором на рабочем поле видна вся плата.

Все компоненты

Масштаб позволяет увидеть все установленные на плату компоненты.

Все выделенное

Выводит на рабочее поле все элементы, которые выбраны.

Изменение масштаба на карте платы

Если была активирована функция показа карты платы, внизу слева будет изображение:

Темно-зеленое поле символизирует всю, а светло-зеленое поле - область, находящуюся на всем рабочем поле. Нажимая на светло-зеленое поле можно перемещать изображение, выводимое на рабочее поле.

Установив курсор на светло-зеленое поле можно щелчками кнопок мышки изменять масштаб изображения:

  • Левая кнопка – увеличение
  • Правая кнопка - уменьшение

Масштаб изображения может быть изменен в любой момент.


Поворот, отражение зеркально и выравнивание объектов

Эти функции выбираются из меню Действие или из панели инструментов. Для вызова этих функций можно также использовать Вы можете также назвать эти функции от всплывающее меню (щелчок правой кнопкой мышки).

Повернуть

Эта функция поворачивает все выделенные элементы по часовой стрелке на заданный угол.

Для выбора угла поворота следует нажать на стрелку в кнопке.

Отразить по вертикали / горизонтали

Все выделенные элементы отобразятся зеркально по горизонтали или вертикали.

Выровнять

Эта функция позволяет выровнять выделенные объекты по заданному признаку из всплывающего меню.

Привязать к сетке

Эта функция позволяет выровнять выделенные элементы по растру сетки. В случае выделения группы объектов перемещается вся группа.


Работа со сгруппированными элементами

Элементы на плате могут быть объединены в группы. Группы облегчают производить выбор, перемещение или редактирование всех членов группы посредством единственной операции. Группы также защищают входящие в них элементы от нежелательных изменений. Нельзя удалить элемент, принадлежащий группе. Для создания группы необходимы, по крайней мере, два элемента. Группы могут содержать любые элементы, а также подгруппы.

Если требуется удалить или изменить индивидуальные элементы группы, необходимо сначала произвести разгруппировку. При разгруппировке сначала разделяется последняя созданная группа. Далее следует повторять операцию с подгруппами до требуемого уровня.

Вызов операции производится выбором Г руппировать или Разгруппировать из пункта Действие главного меню или из панели инструментов. Эти функции также доступны во всплывающем меню (правая кнопка мышки) редактора.

При операции В ставить группирование элементов происходит автоматически.


Связи

Связями можно обозначить соединения между контактными площадками, а также smd-контактами. Это поможет при трассировке печатной платы.

Связи также очень важны для работы с интегрированным автотрассировщиком, который использует их при автоматическом нанесении проводников на плату.

Связи, показанные как тонкие растягивающиеся линии, очень полезны для определения оптимального расположения компонентов. Перемещая компоненты по плате, следует добиться минимального количества пересекающихся линий.

Для включения режима установки соединений следует нажать на соответствующий значек:

Связи могут быть проведены только между контактными площадками и smd-контактами. Щелчком левой кнопки мышки следует указать первый контакт соединения. Линия связи будет тянуться за курсором до следующего контакта, на котором также следует щелкнуть левой кнопкой.

Правая кнопка мышки позволяет завершить режим установки связей.

Удаление существующих связей вручную

Для удаления существующей связи следует нанести ее повторно. При этом она будет удалена.

Автоматическое удаление связей

Этот режим позволяет автоматически удалять связи, в соответствии с которыми уже проложены линии проводников. Режим Удаление связей включается из пункта Действие главного меню или нажатием на значек в панели инструментов. Sprint Layout позволяет анализировать обе стороны печатной платы.

После окончания анализа появится окно с результатами.


Автотрассировщик

Программа включает в себя простейший трассировщик, способный автоматически соединить два намеченных контакта. Контактные площадки предварительно должны быть соединены связью ..

Для выбора этого режима необходимо щелкнуть левой кнопкой мышки по значку:

Появится маленькое окошко автотрассировщика:

Ширина:

Здесь следует выбрать ширину проводника.

Зазор:

Здесь выбирается минимально допустимое расстояние между проводником и другими элементами.

Выбор соединения

Щелчком левой кнопки мышки выбирается линия связи, которую заменит проводник. При перемещении курсора на линию связи, последняя подсветится.

Проложенный проводник будет помещен в активный слой. Следует удостовериться, что активизирован требуемый слой.

Автотрассировщик ищет самый короткий путь для проводника. Это позволяет добиться минимального расстояния между соединяющимися элементами.

Если такой путь существует, проводник будет проложен. В противном случае, появится соответствующее сообщение.

Проводники, проложенные автотрассировщиком, имеют внутри тонкую дополнительную линию. Таким образом можно различать авто- и проложенные вручную.

Удаление созданного проводника

Для удаления проводника, проложенного автотрассировщиком, следует вызвать автотрассировщик и, наведя курсор на проводник, щелкнуть левой кнопкой мышки.

Редактирование проводника

Редактирование проводника, проложенного автотрассировщиком, ничем не отличается от редактирования обычного проводника.

Рекомендации

Для наиболее эффективного использования автотрассировщика следует оптимально расположить компоненты на плате. Кроме того, постараться выбирать наиболее подходящие параметры проводника.


Контроль

Программа находит все соединенные с выбранным проводником элементы.

Для выбора этой функции следует щелкнуть левой кнопкой мышки по значку в левой панели программы:

При переходе на рабочее поле курсор приобретает вид щупа. Выбрав проводник для контроля, по нему следует щелкнуть левой кнопкой мышки. Все элементы, гальванически с ним связанные, приобретут фиолетовый цвет независимо от слоя, в котором они находятся, если имеют контакт с противоположным слоем посредством металлизации отверстий. Правой кнопкой мышки осуществляется выход из режима контроля.


Измеритель

Используя эту функцию, можно значительно облегчить процесс создания платы:

Выбрав измеритель, следует поместить курсор в требуемую точку и, щелкнув левой кнопкой мышки протянуть курсор, удерживая кнопку до следующей точки:

В желтом окошке отобразятся:

  • dX: расстояние по оси X (горизонтальное расстояние)
  • dY: расстояние по оси Y (вертикальное расстояние)
  • Длина: абсолютное расстояние между точками (диагональ)
  • Угол: угол относительно горизонтали

Погрешность измерения уменьшается при увеличении масштаба.

Выход из режима измерения поизводится щелчком правой кнопки мышки или клавишей ESC.


Металлизация

В этом режиме незаполненные участки платы автоматически покрываются слоем меди. Это позволяет сократить время травления и экономит раствор. Металлизацию можно использовать также для создания экранов на ВЧ-платах. Не следует забывать, что изначально металлизированная поверхность не имеет контакта ни с одним из проводников. Следовательно, при необходимости, металлизированные участки надо самостоятельно соединить с требуемыми проводниками.

Режим металлизации может быть использован для всех слоев с медным покрытием. Чтобы активизировать/дезактивировать металлизацию необходимо щелкнуть по соответствующей кнопке, расположенной в нижней части окна программы:

При активизации рядом со значком металлизации появляются символы дополнительного управления. Верхний символ предназначен для изменения зазора между проводниками и металлизацией. Если необходимо изменить зазор у конкретного проводника, последний следует предварительно выделить.

При выборе величины зазора равной нулю, происходит слияние проводника с металлизированным участком!

Области запрета

На печатной плате можно создать участки, которые не будут покрыты медью в режиме металлизации. Для этого следует после нанесения металлизации нажать на заштрихованную кнопку, расположенную под окошком выбора величины зазора. Затем мышкой необходимо выбрать участок, на котором недолжно быть металлизации. Принцип выбора участка идентичен принципу построения полигона. Расположенные в этой области проводники останутся без изменений. Созданные участки можно редактировать как и все остальные элементы платы.

Предупреждение:

В зависимости от расстояния между контактными площадками и проводниками металлизация на некоторых участках может стать слишком узкой и при процессе травления исчезнуть.

Иллюстрация: узкая медная область между проводниками.

В зависимости от требований к плате следует либо увеличить зазор металлизации для удаления узкого участка, либо раздвинуть проводники для получения необходимой ширины металлизации.


Фотовид

Режим фотовида позволяет увидеть плату, какой она будет после изготовления.

Для активизации режима необходимо выбрать значок на левой панели программы:

При этом появится небольшое окно:

Сторона М1/K1

Вид платы со стороны 1.

Сторона M2/K2 (зеркально)

Вид платы со стороны 2 (зеркально).

Коипоненты

На рисунке будут показаны установленные компоненты.

Прозрачность

В этом режиме можно видеть обе стороны платы.

В режиме фотовида для изменения масштаба следует пользоваться колесиком мышки.


Клавиатура

Клавиши клавиатуры можно использовать для удобства работы с программой:

CTRL

При удерживании в нажатом положении отключается привязка к сетке.

КЛАВИШИ КУРСОРА

Используйте КЛАВИШИ КУРСОРА, чтобы переместить выбранный объект на один шаг сетки. Комбинация с CTRL позволяет уменьшить шаг до 1/100 мм.

Клавиши для выбора элемента установки

Эти клавиши можно выбирать по своему усмотрению.

Курсор = ESC

Масштаб =Z

Проводник = L

Контакт = P

SMD-контакт = S

Дуга = R

Полигон = F

Фигура = N

Текст = T

Связи = C

Автотрасса = A

Контроль= X

Измеритель = М.

Фотовид = V

Маска = O

КОСМИЧЕСКИЙ КЛЮЧ

Изменить изгиб проводимой линии.

DEL-ключ

Удалить.

CTRL-Z

Отменить.

CTRL-Y

Восстановить.

CTRL-C

Копировать.

CTRL-X

Вырезать.

CTRL-V

Вставить.

CTRL-D

Дублировать.

CTRL-A

Выбрать все.

CTRL-R

Повернуть.

CTRL-H

Зеркально по горизонтали.

CTRL-T

Зеркально по вертикали.

CTRL-G

Группировать.

CTRL-U

Разгруппировать.

CTRL-W

Перенести на другую сторону.


Работа с несколькими платами

При создании проекта, состоящего из нескольких плат, имеется возможность сохранять их в одном файле. Выбор требуемой платы в проекте производится на панели:

Щелчком левой кнопки мышки по названию платы последняя вызывается на рабочее поле. Щелчком правой кнопки вызывается всплывающее окно с дополнительными возможностями. Эти функции также доступны из пункта Проект главного меню.

Добавить плату

Эта команда добавляет новую плату к проекту. В панели свойств выбираются требуемые параметры.

Свойства платы

Эта команда вызывает панель свойств на рабочее поле для внесения необходимых изменений в параметры платы.

Удалить плату

Для удаления платы из проекта следует выбрать эту команду. При этом необходимо учитывать, что в проекте должна оставаться хотя бы одна плата.

Установить первой/последней

Выбранная плата установится первой или последней в ряду плат проекта.

Переместить вправо/влево

Эти команды перемещают выбранную плату на один шаг вправо или влево.

Импортировать плату...

Эта команда позволяет импортировать все платы файла (*.LAY) другого проекта программы.


Автосохранение

Выбор режима Автосохранения позволяет избежать потери данных при аварийных ситуациях. При выборе этого режима следует установить интервал времени активизации команды автоматического сохранения, для чего необходимо вызвать Автосохранение ... из пункта Файл главного меню.

Если режим Автосохранения активизирован, программа создает резервный файл (*.bak) проекта и автоматически вносит в него изменения через заданный промежуток времени. Основной файл проекта (*.LAY) автоматически не сохраняется, поэтому не следует забывать о его сохранении.

Если по каким-либо причинам файл проекта (*.LAY) испортился, необходимо изменить расширение резервного файла *.BAK на *.LAY, и проект вновь будет готов к работе.


Шаблон

Использование шаблона можно рекомендовать для снятия копий с готовых печатных плат, пропущенных через сканер.

Рекомендованное разрешение картинки 600 точек на дюйм. Более низкое разрешение вызовет потерю качества. Более высокое разрешение потребует большее количество памяти без улучшеня качества.

Загрузка шаблона

Для загрузки изображения следует выбрать Шаблон ... из меню Опции или нажать на соответствующую кнопку в панели инструментов:

Диалог для вывода картинки на экран программы предлагает следующие варианты:

Сторона 1, сторона 2

Изображение может быть установлено на любую из сторон.

Загрузить...

Загружает файл битового массива рисунка.

Удалить

Удаляет битовый массив с рабочего поля.

Отображать

Позволяет прятать или показывать изображение картинки на экране.

Разрешение

Выбирается разрешение и соответственно масштаб отображаемой картинки.

X/Y-сдвиг

Перемещение картинки по рабочему полю.

Цвет

Цвет показа картинки (при чено-белом варианте).

Диалог из меню Опции может быть вызван в любое время для внесения изменений.

Просмотр шаблона

В нижней части программы при загруженном шаблоне появится окошко:

Нажимая на эти кнопки можно прятать или показывать шаблон.

Печать шаблона

При качественном изображении рисунка, его можно использовать при печати, добавив вручную необходимые элементы.


Макросы

Библиотека компонентов программы состоит из так называемых макросов. Макросы - маленькие композиции элементов (главным образом, такие компоненты как резисторы, транзисторы, и т.д.).

Библиотека программы Sprint Layout состоит из ряда наиболее часто используемых компонентов. При необходимости можно добавлять собственные.

  • Использование макросов
  • Создание макросов
  • Удаление макросов


Работа с макросами

Работа с библиотекой

Для использования компонентов библиотеки необходимо вызвать ее на экран. Для этого следует выбрать пункт Библиотека из меню Опции, или нажать на соответствующую кнопку в панели инструментов:

Панель библиотеки появится в правой половине экрана.

Далее следует выбрать требуемую группу. Щелчок по значку "+" раскрывает сотав группы.

Щелчок по выбранному элементу приводит к появлению его в окне предварительного просмотра.

Для переноса компонента на рабочее поле следует нажать на его изображение и перетянуть в требуемое место.

Компонент будет всегда помещаться на активную сторону платы.

В случае необходимости, компонент будет изображен зеркально. Это зависит от предварительного выбора и стороны платы.

Дополнительные функции

Ниже списка компонентов находятся кнопки:

Сохранить

Сохраняет выбранные на рабочем поле элементы как макрос.

Удалить

Удаляет выбранный из списка компонент из библиотеки.

Металлизация отверстий

Все контактные площадки выбранного компонента будут с металлизацией.

Зеркально

Переворачивает изображение компонента.

Перенести

Изменяет сторону установки компонента.

Для удаления библиотеки с экрана следует использовать значок (X) в заголовке библиотеки

Примечание:

Размер окна библиотеки можно произвольно изменять, наведя курсор мышки на границу и потянув за нее.


Создание элемента (макроса) библиотеки

Для создания макроса его следует изобразить на рабочем поле, используя стандартные инструменты программы.

Желательно, чтобы изображение находилось на стороне 1 рисунка платы.

Пример:

Скажем, требуется создать макрос для 14-выводной микросхемы DIP.

Изображение корпуса должно находиться на стороне 1(К1) Контактные площадки, следовательно, будут находиться на стороне 2(М2).

Сначала выбирается слой М2, в котором устанавливаются контактные площадки в количестве 14 штук (2х7). Теперь следует выбрать активным слой К1 и нарисовать контур микросхемы с обозначением ключа возле вывода 1.

Далее следует выбрать пункт С охранить как макрос в меню Файл, или щелкнуть соответствующей кнопкой в библиотеке макросов.

Экономия времени

Функция С охранить как макрос экономит время, т.к. файл отсылается сразу именно в библиотеку. Расширение по умолчанию *.LMK для макроса добавляется автоматически.

Можно сохранить всю плату или ее часть как макрос. Для этого следует выделить сохраняемый участок и произвести операцию С охранить как макрос.


Удаление макросов

Для этой операции следует нажать кнопку У далить в окне библиотеки. После подтверждения выделенный компонент будет удален.

Для удаления можно воспользоваться непосредственно Windows, войдя в папку библиотеки программы и выбрав требуемый компонент с расширением(*.LMK).


Создатель макросов

Этот создатель помогает при добавлении новых компонентов в библиотеку.

Для его активизации следует выбрать Создатель макроса ... из меню Опции.

Есть 5 различных доступных типов расположения контактных площадок:

  • Однорядный (SIP)
  • Двухрядный (DIP)
  • Четырехсторонний(QUAD)
  • Кольцевой
  • Двойной кольцевой

При выборе требуемого типа, его изображение появится в нижнем окошке.

Затем следует определить остальные параметры.

Контакты

Здесь выбирается тип (сквозной или SMD) и размер.

Количество выводов

Здесь выбирается число выводов по сторонам компонента.

Расстояние

Здесь выбирается величина шага между контактами.

При нажатии на кнопку OK на плате появится созданный элемент.


Установки

Перед началом создания нового проекта следует выбрать пункт Установки... из меню Опции.

В открывшемся окне можно задать параметры проекта.

Визуализация

Единицы

Следует произвести выбор единиц измерения: мм или мил (1 мил = 1/1000 дюйм).

Отверстия

Цвет отображения отверстий по желанию можно выбрать либо совпадающим с цветом фона, либо белым.

Виртуальные узлы на линиях

Активизирует изображение виртуальных узлов в середине каждой прямой линии.

Линии перекрестия

Активизирует отображение двух тонких перекрещивающихся в месте положения курсора линий размером с рабочее поле.

Зеркально макросы и текст на стороне 2

По умолчанию текст и компоненты автоматически отображаются зеркально при установке на нижнюю сторону платы. В этом пункте можно изменить установку.

Карта платы

Выбор пункта позволяет отображать слева внизу символическое изображение всей платы с ярким участком видимой на рабочем поле части платы.

Всплывающие названия функций

Активизирует всплывающие окна при подведении курсора к значку функции.

Ограничить толщину шрифта

Шрифт толщиной менее 0,15 мм может не отобразится при использовании шелкографии при изготовлении платы.

CTRL для запоминания параметров

Если произведен выбор объекта, можно,щелкнув клавишей Ctrl, занести его параметры в буфер и при следующей установке подобного элемента, последний будет иметь такие же параметры .

Использование шага 0,3937 вместо 0,4

Программа обычно использует для создания файла HPGL шаг 0,4. Это означает, что 1 HPGL-единица равна 0,4 мм. Для некоторых плат следует изменить шаг.

Затемнение металлизации

При выборе этого пункта цвет металлизации станет темнее проводников на выбранном слое.

Цвета

Если цвета по умолчанию не устраивают, можно их изменить. Программа позволяет создать 4 комбинации цветосочетаний, например:

  • По умолчанию
  • Схемный
  • Платный
  • Чертежный

Выбрав один из вариантов (кроме по умолчанию), можно, нажимая на соответствующие квадратики, выбрать требуемые цвета.

При нажатии на кнопку У становить как стандартный, все цвета в выбранной комбинации установятся такими, как у производителя программы.

Директории

В белые поля следует заносить полный путь к искомой директории. Кнопками "..." можно выбрать существующую директорию.

Примечание:

Если оставить поле пустым, программа запомнит директорию, которая была до внесения изменений.

Библиотека

При перемещении папки библиотеки необходимо изменить путь поиска макросов, нажав на кнопку И зменить.

Кнопка Сброс перезагружает папку библиотеки в директорию по умолчанию.

Возврат

Эта функция позволяет при создании платы отменить до 50 последних действий.

Imax

Максимально допустимый ток проводника будет вычислен и отобразится в панели Свойства при выборе.

Клавиши

В этой панели можно выбрать наиболее удобные клавиши клавиатуры для вызова той или иной функции.


Панель свойств

Панель свойств позволяет редактировать выбранные элементы без вызова диалогового окна.

Активизировать панель следует, выбрав пункт Свойства из меню Опции или нажатием на соответствующую кнопку в панели инструментов:

Панель свойств появляется справа.

Панель свойств отображает параметры выделенного элемента. Если, например, производится выбор контактной площадки, ее параметры можно редактировать:

Аналогично с остальными элементами.

Панель свойств не может отображать группу различных элементов.

Если не будет выбрано ни одного элемента, панель свойств будет отображать параметры платы


Контроль по параметрам (DRC)

При создании печатной платы иногда допускаются ошибки, которые нарушают некоторые ограничения. Эти ограничения называются "Правилами Проекта". Функция DRC программы в состоянии проверить некоторые важные правила проекта, например минимальное расстояние разрешения между 2 медными проводниками, и т.д.

Чтобы проверять плату по заданным параметрам, следует активизировать функцию DRC. Для этого необходимо выбрать DRC-контроль из меню Опции или щелкнуть по соответствующей кнопке в панели инструментов:

В правой части экрана появится окно DRC.

В этом окне следует задать требуемые для данной платы контролируемые параметры.

Минимальный зазор между проводниками:

Минимальное разрешенное расстояние между проходящими рядом проводниками.

Минимальный зазор между отверстиями:

Минимальное разрешенное расстояние между соседними отверстиями.

Отверстие>:

Минимально допустимый диаметр отверстия.

Отверстие<:

Максимально допустимый диаметр отверстия.

Мин. Линия(М)

Минимально допустимая ширина проводника.

Мин. бордюр.:

Минимально допустимая ширина меди, окаймляющей отверстие в контактной площадке.

Мин. Линия(К)

Минимальная толщина линии, определяющей форму компонента.

Контакт под компонентом:

Запрет на наличие контактных площадок под установленными на плату компонентами.

Отверстия в SMD-контактах:

Запрет на наличие отверстий, проходящих через smd-контактные площадки.

Отсутствие маски:

Запрет на отсутствие маски по олову на контактных площадках.

Маска на проводнике:

Запрет на использование маски по олову на проводниках и полигонах.

Запуск DRC

После того, как сделан выбор параметров контроля, можно начинать.

Вся плата

В этом режиме будет проведен контроль для всей платы.

Окно

В этом режиме контроль будет проведен только для видимой на экране части платы.

Результат DRC

После DRC, все обнаруженные ошибки будут выведены в списке окна панели DRC. Каждая строка показывает соответствующий слой и обнаруженную ошибку. Все обнаруженные ошибки дополнительно отобразятся на плате в виде белых штриховок. Каждую ошибку можно просмотреть отдельно, щелкнув левой кнопкой мышки по соответствующей строке. Нажав на клавишу В ыбрать все, на плате вновь можно увидеть все ошибки.

Примечание:

Двойным щелчком мышки по требуемой строке на экран вызывается соответствующая ошибка при увеличенном масштабе отображения.


Редактирование маски

Маска по олову создается в программе автоматически. Маски создаются на всех контактных площадках и smd-выводах компонентов.

Иногда необходимо нанести маску на проводник, чтобы оставить его без защитного слоя лака.

Для этого необходимо войти в режим редактирования масок, выбрав соответствующую кнопку на левой панели программы:

При этом все элементы, на которых нанесена маска, будут подсвечены белым цветом, а курсор примет форму стрелки без хвостика.

Щелкая левой кнопкой мышки по выбранному элементу, можно удалять или добавлять маску.

Восстановить исходное состояние маски (все контактные площадки и SMD-выводы) можно, выбрав пункт У становить маски по умолчанию из меню Действия.


Информация о проекте

Эту функцию следует использовать для добавления необходимых комментариев к проекту.

Вызов окна комментариев производится нажатием на кнопку:


Печать

Вызов команды Печать осуществляется из пункта Файл главного меню или из панели инструментов:

При этом на экран выводится изображение для просмотра и диалог печати, предлагающий несколько вариантов.

Предварительный просмотр покажет рисунок платы, который будет выведен на печать.

Выбранный формат бумаги отображается в виде белого листа. Красная штриховая линия обозначает допустимые границы печати. Размер этой области зависит от выбранного принтера и его драйвера.

Перемещая мышкой изображение по листу, следует добиться наиболее удачного.

На левой стороне диалогового окна отображаются возможные варианты для печати:

  • Слой
    С     ледует выбрать слой платы, который будет выведен на печать. Цвет каждого слоя можно выбрать, щелкнув левой кнопкой мышки по соответствующему квадратику.
  • Дополнительно
    В     этом слое можно выбрать отображение масок по олову и карту центровки отверстий.

    Маска
    Маска по олову предназначена для нанесения на плату участков, защищающих участки поверхности от изолирующего лака.
    Параметры масок выбираются в окне, открывающемся при щелчке по кнопке Параметры.

    Отверстия
    П     ри выборе этого пункта на печать будет выведена карта отверстий с указанием центровки и диаметров.
    Высота текста выбирается в окне параметров.
  • Зеркально
    П     ри выборе этого пункта плата будет отображаться (и печататься) зеркально.
  • Перекрестия, Контур
    Тонкие линии перекрестий будут добавлены к рисунку по углам платы .
    На рисунок добавляется тонкая линия, обозначающая контур платы .
  • Шаблон
    Выбор этого пункта позволяет вывести на печать изображение загруженного шаблона.
  • Негатив
    П     ри выборе этого пункта отображение платы будет негативным (кроме шаблона).
  • Сетка
    П     оказывает сетку на странице предварительного просмотра. Это позволяет наиболее удобно разместить рисунок. Сетка на печать не выводится.
  • Информация
    В     нижней части листа отображается информация о проекте и дата.
  • Масштаб
    П     озволяет менять масштаб печати от 10% до 1000%.
    Используйте 1:1 для распечатки реального размера.

Верхняя панель диалога печати:

  • По центру
    Изображение автоматически перемещается в центр листа.
  • В буфер
    Изображение автоматически копируется в буферную память компьютера и может использоваться другими графическими программами.
  • Копии
    Н     а одном листе можно разместить несколько изображений. Количество копий и интервалы между ними выбираются в появляющемся окне
  • Коррекция
    Н     екоторые принтеры искажают при печати реальные размеры. Это определяется пробным путем.
    Пример: линия имеет длину 200 мм, а принтер печатает линию длиной 201 мм. В этом случае следует внести коэффициент коррекции 200 мм / 201 мм = 0,995. Теперь принтер напечатает истинную длину.
  • Принтер
    Выбор принтера для печати. Текущий принтер показан в заголовке диалога печати.
  • Печать
    Старт печати.
  • Выход
    З     акрывает диалоговое окно печати и возвращается к редактору Sprint Layout.


Экспорт в формате BMP

Эта функция создает файл (*.BMP) битового массива, который может использоваться с другими программами. Битовый массив создается из слоев, видимых на рабочем поле. Для создания файла битового массива следует выбрать Экспорт-> Картинка (*.BMP) из пункта Файл главного меню.

В появившемся окне производится выбор характеристик создаваемого изображения:

  • Цветное или черно-белое
  • Качество передачи

Цвет

Режим передачи цвета следует выбирать только при действительной необходимости. Одноцветный битовый массив, который использует 500 килобайтов, нуждается приблизительно в 12 мегабайтах, если экспортируется в цветном режиме с тем же самым разрешением! Это может занять значительное время.

Для сохранения ресурсов даже при цветном изображении можно осуществлять создание файла в черно-белом виде.

Требуемый объем памяти отображается в окне выбора характеристик.

Разрешение

Для выбора разрешения следует мышкой передвинуть ползунок в требуемое положение. Необходимо помнить, что большое разрешения (высокое качество) нуждается в большем количестве ресурсов памяти, чем более низкое разрешение. Объем требуемой памяти отображается в окне выбора характеристик. Желательно уменьшать разрешение до минимально приемлемой величины. Это особенно важно при передаче цветного битового массива.

Для создания файла экспорта следует нажать ОК. При этом откроется диалоговое окно, в которое заносится название файла и выбирается директория его сохранения.

Файл будет иметь расширение *.BMP, и может быть открыт почти всеми графическими программами.


GIF-экспорт

Эта функция создает GIF-файл (*.GIF), который может использоваться в других программах. GIF-файл создан из слоев, которые являются фактическими видимыми на экране. Для создания такого файла следует выбрать Эспорт-> (*.GIF) из пункта Файл главного меню.

Качество

Используя ползунок, следует выбрать разрешение битового массива. Необходимо помнить, что большое разрешения (высокое качество) нуждается в большем количестве ресурсов памяти, чем более низкое.

Далее следует нажать ОК, чтобы создать GIF-файл. Откроется диалоговое окно в котором необходимо дать имя файлу и выбрать директорию сохранения.

Файл будет иметь расширение *.GIF, и может быть открыт многими графическими программами.


JPG-экспорт

Эта функция создает JPEG-файл (*.JPG), который может использоваться другими программами. JPG-файл создан из слоев, которые являются фактическими видимый на экране. Для создания файла необходимо выбрать Экспорт-> JPG (*.JPG) из пункта Файл главного меню.

Качество

Используя ползунок, следует выбрать разрешение битового массива. Необходимо помнить, что большое разрешения (высокое качество) требует большее количество ресурсов памяти, чем более низкое.

Далее следует нажать ОК, чтобы создать JPG-файл. Откроется диалоговое окно в котором необходимо дать имя файлу и выбрать директорию сохранения.

Файл будет иметь расширение *.JPG и может быть открыт многими графическими программами.


EMF-экспорт

Эта функция создает файл расширенного формата, который может использоваться в других приложениях Windows. Файл создается из видимых на рабочем поле слоев. Для создания такого файла следует выбрать Экспорт-> (*.EMF) из пункта Файл главного меню.

Откроется диалоговое окно, в котором следует задать имя файла и директорию сохранения. Файл будет иметь расширение *.EMF.


Экспорт файла в формате Gerber

Программа Sprint Layout может создавать Gerber-файлы RS274-X, которые используются большинством изготовителей печатных плат. Необходимо создавать файл Gerber для каждого слоя (медь, компоненты, маска) и описывать полностью в сопроводительной записке их назначение.

Для создания файла необходимо выбрать Экспорт-> Гербер из пункта Файл главного меню. Диалоговое окно предлагает несколько вариантов, которые являются доступными в формате Gerber.

Прежде всего следует выбрать слой, который должен экспортироваться. При этом автоматически устанавливается выбор зеркальности. При необходимости параметр может быть изменен.

Передать зеркально

Этот выбор переворачивает изображение слоя. Обычно слои для стороны 2 зеркальны.

Контур платы

Этот выбор добавляет простой контур платы к файлу.

Отверстия

Этот выбор следует сделать, если не создается отдельный файл сверловки.

Центровка отверстий

При выборе этого пункта в файл будут переданы координаты центров отверстий.

Зазоры маски по олову/клею

В этом пункте выбираются необходимые характеристики масок по олову, а также, в случае автоматизированного производства, по клею SMD-компонентов.

По окончании выбора пунктов следует нажать С оздать файл.

Примечание:

Перед созданием файла следует проконсультироваться с изготовителем и выяснить его требования к экспортному файлу.


Экспорт сверловки отверстий

Excellon-файл используется при передаче изготовления платы на промышленное производство. Он содержит информацию о диаметре и координатах всех отверстий на плате.

Для создания файла следует выбрать пункт Экспорт-> Сверловка (EXCELLON) ... из Файл главного меню.

Передать

В этом пункте выбирается тип отверстий для передачи в файл. Отдельный файл «с металлизацией» иногда бывает необходим на производстве.

Координаты

Здесь следует выбрать сторону платы, относительно которой будут рассчитаны координаты отверстий.

Сортировать

Этот выбор сортирует отверстия по геометрическим характеристикам.

Единицы измерения

Необходимо правильно выбрать единицы измерений. Некоторые машины могут только работать с дюймами.

Выбор У далить незначащие нули необходим для некоторых промышленных программ станков с ЧПУ.


Файлы для фрезеровки (экспорт HPGL)

Использование фрезерных станков при создании печатных плат растет по своим масштабам.

Для многих производителей это становится наиболее выгодно, т.к. исключает химические процессы. Программа Sprint Layout позволяет создавать экспортные файлы, используемые на производстве со станками ЧПУ.

Описание состоит из 2 частей:

Создание экспортного файла (HPGL)

Практическое использование файлов HPGL


Создание экспортного файла для фрезерного станка (HPGL)

To describe the export functions we sketched a small sample PCB that will show all the functions of this new option.

As you can see this is a double-sided PCB

Before we start the export dialog, we must decide what text on the PCB is single LINE or outline.
All text segments that are to be milled as single LINE must be highlighted before the start of the PLT option.

Since we want to store the top layer C1 (blue) first, we will highlight the text segment "IC - test", as we want it to be milled single LINE. The text segments "Abacom" and "Logo" are to be milled like our tracks outline and therefore need no further attention.

We enter the function as follows:

File - > exporting - > milling files - > isolation milling(HPGL, *plt)

The following dialog appears:

In this dialog we select the following options:

Layer

Since we want copper side 1, we select the Layer C1.

Milling Width

This is the width of the milled isolation path. It is necessary to know what the milling tool width that will be used to mill the PCB is. In our case it is 0.25mm.

Text

We select the text options for our highlighted text as "singleline", and for the un-highlighted text we select "outline"

Mirrors

Since we are dealing with the top side of the PCB layer C1, we will not need to mirror the PCB.

Options

Mark drill holes for centering

If the option "Mark drill holes for centering" is activated, all pads and eyelets receive a centering point. The milling tool will drive to the center of each pad or eyelet and mill a small hole to the same depth as the isolation path.

This function was included to allow good alignment of CNC drills during the hole drilling process and reduce the chance of the high speed hole drills from bending and breaking.

The only disadvantage of this function is an extension of the isolation milling job by the additional centering points.

In our example we decided for the centering holes.

Reference holes

The following "Reference holes" option affects all files that are used in the manufacturing of our PCB.

You can set several alignment holes for our PCB. It is important to remember that these alignment holes appear at the same place in all files.

That means: The zero point of the individual Layers are always alike.

Drillings

The last part in this dialog is dedicated to producing the hole drilling PLT files. This option is perfect for those who don't have the Excellon function on there milling software. Sprint layout can produce Excellon files if need, this function can be found under the following menus, export, Drill data (Excellon).

As our PCB has two different hole diameters (0,6 and 0.8 mm), we select the option "Each diameter in a extra file" this will produce a PLT file for each hole size.

We confirm our selections with OK.

The following window indicates the progress of the outlining production.

Next we get a save file dialog.

Here we give a name and destination directory for the PLT files "Sample C1.PLT".

The drilling files are put in the same directory. The drill files are automatically named and are self-describing.

Now we will deal with the back C2 (green) layer of our PCB. Again all text segments that are to be milled as "singleline" must be highlighted before the start of the PLT option.

Like before we select the "isolation milling" option.

This time we select the Layer C2.

The milled isolation path width and text attributes should still be set from the previous time.

We will select to reflect "Mirror horizontal" to reverse the PCB output as we are milling from the bottom and not the top.

Our options for "Reference holes” have also been copied over from the first layer setup.

As we have already made our drilling files from the C1 side, we will deactivate "Mark drill holes for centering" and we will select "No output” for the Drillings options.

We confirm our options with OK and again we are presented with a file dialog.

Here we see the files that were produced previously. We want to store our C2 side in addition to these. So we give a name for the C2 PLT files "Sample C2.PLT”.

Producing a PCB outline PLT file

Last of all we want to mill our PCB outline, mounting holes and any cutouts. This can be accomplished easily in a milling job with Sprint-Layout.

You will have to draw the outline of your PCB, mounting holes and any cutouts on the outline layer O (white). You can only use tracks, circles and polygons to draw your outline. All other elements e.g. pads are ignored by the PCB Outline Milling function.

The zero point or reference holes of the milled isolation and drilling files from our project are used here also. Thus it is possible to mill the PCB outline after the C2 layer has been milled (after appropriate milling tool change) with out repositioning the PCB.

Note: the PCB perimeter outline is milled in the center of the drawn track so it is important to select a track width that is the same as the milling tool that will be used to mill the PCB.

Looking at our sample PCB again.

We have our PCB-outlined on layer O (white). Our PCB has 4 mounting holes (5,5mm), a round outbreak (16mm) and the outer contour. The exact diameter of the holes we can configure in the properties-panel after selecting the circle:

During the input of the diameter note that you must include the width of the drill. Since the tool will mill concentrically around the radius, the milled hole width will be wider. You must take the milling tool width off from the diameter of the hole, in order to obtain the correct hole width result.

In our case we want a hole of 5,5mm and our milling tool has a width of 1mm. The input in the circular arc dialogue diameter must therefore be 4.5 mm.

If you draw PCB outlines, make sure that you first draw outbreaks, and holes within the PCB outline then draw PCB outline. Remember, what was drawn first will also be milled first.

We first highlight all elements that are going to be used to produce the PCB outline, cutouts and holes.

We start the dialogue as follows:

File - > exporting - > milling files - > PCB Outline milling(HPGL, *plt)

Since we want to mill the PCB outlines from the back of our example PCB C2, the outline (like C2) must be mirrored. We select "Mirror horizontal".

The "Reference holes" were copied over automatically.

We click on OK and are presented again with our file dialogue.

We name our plate outline file "Outline.PLT" and click again on "Save".

Now we have all the files required to manufacture our PCB on a milling plotter.

  • Sample C1.PLT Copper side C1, PCB top
  • Sample C2.PLT Copper side C2, PCB bottom
  • Outline.PLT PCB outlines, cut outs and mounting holes
  • DRIL_60.PLT PCB pads that have 0.6 mm holes
  • DRIL_80.PLT PCB pads that have 0.8 mm holes


Практическое использование файлов HPGL

Это интересно посмотреть, но использовать в России – вряд-ли.


Просмотрщик

Просмотрщик может использоваться для просмотра и вывода на печать.

Он состоит из единственного EXE-файла: VIEWLAYOUT50.EXE

Просмотрщик есть в свободном доступе на странице:

  • www.abacom-online.de (немецкая версия)
  • www.abacom-online.de \uk (английская версия).